this should be /emote/{emoteId}
(using whatever preferred case). If in the future we have /resource/{id}/subresource/{id}
then there's a problem/ambiguity in terms of naming/inconsistency.
this should be plural. the vast majority of my personal preferences/reasoning coming from the google AIPs:
we should probably not be using the package-lock.json and be importing this into the pnpm workspace so that dependencies are deduplicated and we have a single lock file for the entire project. I can fix this up if you would like
The fact that typespec just defaults to "latest" for versions for things is insane
Should we just use INTEGER
and just use the RGB value instead of as a string? saves data at the very least
I'm not very familiar with toolchain
tbh. is there a concern with toolchain local
?
I personally of the opinion that having an env file that sets the values for each environment is better to go, much more portable and swappable over having to pass a long list of args (which can…
I don't like the idea that we automatically run the up migration every time the application starts up. Is this the best way to do it? I would prefer it was a separate command or something.
I agree with your todo. I can't think of any benefit of having users with no name